Clover has indicated the degradation in service has been resolved; we are going to continue to monitor. Please contact us at help@goresero.com if you continue to experience disruptions.
Posted Jun 05, 2026 - 14:50 EDT
Investigating
We have received reports of Clover transactions failing periodically in the last 20 minutes; we are also continuing to see successful transactions. The errors we see are originating outside of CampusCloud, we are investigating further and have reached out to the Clover team for additional information.
Posted Jun 05, 2026 - 14:42 EDT
This incident affected: CampusCloud Payment Services (Clover Credit Card Processing).