Clover has indicated a fix is in place and we are seeing successful credit card transactions, we will continue to monitor for any ongoing concerns. We have requested additional clarification from Clover/Fiserv on the root cause of these issues.
Posted May 14, 2026 - 13:50 EDT
Identified
We have identified that Clover is responding to credit card requests with the message "The payment request was canceled." despite there being no cancellation from users or from CampusCloud; we are in contact with the Fiserv team to assist.
Posted May 14, 2026 - 13:42 EDT
Investigating
We are investigating reports of Clover processing issues; we will provide additional updates as they become available.
Posted May 14, 2026 - 13:37 EDT
This incident affected: CampusCloud Payment Services (Clover Credit Card Processing).