Clover European Union Outage
Incident Report for resero CampusCloud & SmartLockers
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 21:37 EDT
Monitoring
Clover is reporting a major outage in their European Union systems; this should not have any effect on US-based processing and we are not currently seeing any concerns, but we will continue to monitor the situation.
Posted Sep 12, 2024 - 09:18 EDT
This incident affected: CampusCloud Payment Services (Clover Credit Card Processing).