WPS has reported a false alarm in their reporting; we did see a small spike in errors at approximately 12:30pm Eastern that has been reported to Clover, but that appeared to be a limited impact. We will continue to monitor.
Posted May 15, 2026 - 13:05 EDT
Investigating
We have been notified by the WPS team via status.watchmanpaymentsystems.com that they are seeing increased error rates with Clover; we will track this concern and update as needed, below is the full update from WPS.
Please be aware that we are seeing increased error rates from Clover Credit/Debit transactions. This appears to be similar to the issues that have occurred the last 2 weeks at about this time. We have notified Clover, and the issue may already be resolved by the time this status update is pushed. We have not been given a root cause at this point, but they have said that it is a high-priority to find and fix permanently.
Posted May 15, 2026 - 12:56 EDT
This incident affected: CampusCloud Payment Services (Clover Credit Card Processing).