Clover/Fiserv Reported Issue

Incident Report for resero CampusCloud & SmartLockers

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 17:52 EDT

Update

We are seeing successful transactions, we will continue to engage with the Clover team and monitor the situation.
Posted Jun 26, 2026 - 17:00 EDT

Investigating

We are seeing an increase in failed credit card transactions with Clover; our payment partners at WPS are seeing similar issues with external customers as well. We are engaging with the Clover team to investigate further.
Posted Jun 26, 2026 - 16:52 EDT
This incident affected: CampusCloud Payment Services (Clover Credit Card Processing).