Clover has finally indicated there were latency issues earlier today and has indicated they are now resolved; we will continue to follow up with them for a root cause analysis of the concern and guidance about what is being done to prevent such concerns in the future.
Posted May 01, 2026 - 15:40 EDT
Monitoring
Although we've not received an official confirmation from Clover, we have begun to see transactions resume processing as expected; we will continue to monitor the situation and work with our partners to determine what occurred.
Posted May 01, 2026 - 14:08 EDT
Investigating
We are investigating a potential Clover system degradation; we have not seen an update from Clover identifying an issue, but are beginning to see potential degradation in their system based on failure rates. This concern is external from CampusCloud, but we are working with partners to review.
Posted May 01, 2026 - 13:14 EDT
This incident affected: CampusCloud Payment Services (Clover Credit Card Processing).